Primary API Elevated Response Latencies and Errors

Incident Report for Teak.io

Resolved

This incident has been resolved.
Posted Jul 24, 2026 - 21:28 UTC

Monitoring

A fix has been implemented. Response times and error rates have returned to normal. We are continuing to monitor.
Posted Jul 24, 2026 - 20:15 UTC

Investigating

We are currently investigating elevated response times and error rates for the primary API
Posted Jul 24, 2026 - 20:02 UTC
This incident affected: Primary API.