AWS outage in us-east-1 causing major service disruption

Incident Report for Teak.io

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 10:47 UTC

Update

We are seeing full system recovery. We are continuing to monitor this situation while AWS continues their recovery.
Posted Oct 20, 2025 - 09:53 UTC

Monitoring

We are seeing recovery across multiple systems. We have reenabled event processing and notification and email sends.

We are also seeing recovery to universal link resolution.

We will continue to monitor this situation.
Posted Oct 20, 2025 - 09:41 UTC

Update

We are seeing some service recovery at this time.

We are continuing to keep notification and email sending and event processing on hold while we monitor the situation for full recovery.
Posted Oct 20, 2025 - 08:39 UTC

Identified

We are currently experiencing an outage of rewards and universal link resolution caused by the failure of multiple AWS services in us-east-1.

To mitigate player experience and potential data loss, we have paused all notification and email sending and event processing while AWS continues to experience failures.

We are actively monitoring the situation and will provide another update in 30-45 minutes or when new information is available.
Posted Oct 20, 2025 - 08:04 UTC
This incident affected: Dashboard, Primary API, Metrics API, Notifications, Rewarding, Social Sharing, Gifting, Active Users, and Deep Linking.