Elevated API error rates and latencies

Incident Report for Teak.io

Resolved

This incident has been resolved.
Posted Jan 22, 2026 - 02:23 UTC

Monitoring

API error rates and latencies have returned to normal levels. The root cause was a hardware failure in our primary DB, resolved by failing over to a hot standby.

We are continuing to monitor the API and database.
Posted Jan 22, 2026 - 01:47 UTC

Update

We are continuing to investigate this issue. We are seeing an improvement in error rates and latencies, but both remain elevated.
Posted Jan 22, 2026 - 01:33 UTC

Investigating

We are currently investigating elevated latencies and error rates for our primary API.
Posted Jan 22, 2026 - 01:03 UTC
This incident affected: Primary API.